报异常:java.lang.UnsupportedClassVersionError: javax/annotation/ManagedBean

笔者整理springboot项目时,报异常:

java.lang.UnsupportedClassVersionError: javax/annotation/ManagedBean : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[na:1.6.0_10-rc2]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621) ~[na:1.6.0_10-rc2]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124) ~[na:1.6.0_10-rc2]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260) ~[na:1.6.0_10-rc2]
    at java.net.URLClassLoader.access$000(URLClassLoader.java:56) ~[na:1.6.0_10-rc2]

解决方案:

JDK版本问题,jdk6升级到jdk7就OK了。

用户评论
提问者
云码官方
最近登录:03月19日 20:53
热门问答
437 阅读 0 回答